BioMod 2002
Modeling in BASIC - 1rst Session
|. Starting up the modeling language Visual Basic 6

- Start up your Windows 2000 machine (always restart if someone worked before you).

- Open MyComputer and insert the Biomodeling floppy disk (we will use ZIPs later in the course)

- Open the 31/2 inch floppy.

- Open the Week1 folder & open the folder MasterModel.

- Pick from the View menu the choice Large Icons.

- Double click on the MasterModel file that looks like a bunch of paper forms with some colored
blocks (i.e. the Project file). Don't open any file with the Windows flag on it or the simple blue &
white form.

You have now loaded your major basic modeling tool for the course and are almost ready to
work.

[I. Running a model
The model you have loaded is a highly simplified (and inaccurate) model of population growth
vs. time.

To Run it in order to see how it behaves
From the Run menu pick Start (F5)

After the model starts to Run successively
- click Continue
-Select Graph for an output and click Go
- At the upper right click Run Model

The model runs and its output (a graph) appears in the Graphical Output window. It will
run until it is complete at 50 days and then pause. Study the output pattern. Clearly the
population (Y-axis) grows as a straight line function of time, starting at no population and
growing linearly for the entire 50 day period.

[ll. Labeling outputs of your model

Click on Label Graph choice (upper right) and type in " My first Model - Your Name "

Make the Font BOLD. Click OK

Click OK again to close the title entry form.

Move your arrow cursor to where you wish the label to begin and click. Your label becomes
deposited on the graph.

Play with labeling (and Erasing) as much as you wish.

IV. Printing model outputs

Select the Print command button (on the right) and follow the Print dialog box instructions.

Your printed output should appear in the Dana 181 printer or whatever printer you have selected
on the Desktop under Start (lower left) -> Settings -> Printers.

V. Pick Exit - (lower right) to end a session and return to the model code itself.

VI. Anatomy of a model Listing
The [ Code ] window you are looking at contains the instructions (the List) that tells
VBASIC how to run your model. To make changes in a model (or create a new one) your edit




the text in the code window. The final order of instructions in your code window determines what
happens in the model the next time you Run it.

Vbasic runs your model by sequentially executing the steps you give it in the code
window List, working from top to bottom. Each time it encounters an instruction to go execute a
separate subsection (e.g. scroll down and find PlotPoint) it does so (i.e. plots the point) and then
returns back to continue on with the next step in the sequence.

To examine the List from its beginning scroll up to the top. Examine the first 10 or so lines
(shown also below). You should recognize some of the series of steps you just watched when
you ran the model several moments ago.

'***********************G et Val u eS************************

'‘Define Graph Maxima and Minima
xMin =0
xMax =50
yMin =0
yMax = 50

‘Label graph X- and Y-axis ==> use no more than 20 letters
'per label
Xlabel = "Time (days)"
"Population Density"

Lines to particularly note are where the labels for the x and y graph axes are assigned and
where the x and y axis maxima and minima are specified (remember 0 to 50 days?).

VII. How to Edit (i.e. change) a model Listing

This is a process you will repeat over and over in the course. New models are not written
denovo; they are simply constructed by editing preexisting models just as you will do right
now.

A) Changing X & Y graph labels

To obtain practice in changing (editing) a Listing, we will first alter X and Y graph
labels. Look several lines below and notice the main model program calls a subroutine
"SetUpGraphAndAxis" to which are passed, among other items, the x and y axis labels you
type into the List. We will now change those labels to be more appropriate for a specific short
term experiment involving the growth of bacteria.

1) To locate the Xlabel in the List.
Scroll up to near the model top until you see the section beginning with:
' Label graph X- and Y-axis

This is the section you wish to edit. (Be aware that you can scroll more rapidly by clicking
in the stippled area between the scroll arrows.)

Editing a BASIC model is much like editing text with a word processor. All text entry and
editing takes place in the Code List window using the Cut, Copy and Paste commands from
the Edit menu and your <delete> key. You enter new text at the insertion point (the thin I-
blinking cursor) either by typing it from the keyboard or by 'Paste'ing' it in from the Clipboard.



<Delete> (or its equivalent <Backspace>) deletes characters behind (i.e. to the left of) the
insertion point. Dragging the mouse across text selects it (selected text turns dark) and you
can Cut or Copy the selection just as you would with a word processor.

2) To change the Y axis label from 'Population Density' to '‘Bacteria’:
-> Look for the line:
Ylabel = "Population Density

-> Click between the lower case y and " (quotation mark) near the end of the line. This
places the blinking insertion point at the end of the word ‘Density’.

-> Backspace out Population Density. Notice that backspacing deletes to the left of the
insertion point and leaves the quote marks intact.

-> Type in Bacteria for bacteria. Your List line should now read

Ylabel= "Bacteria"

If the quotes are missing, add them back by moving the insertion point to where you wish it

to be and then make appropriate changes.

Let's try out your changed labels.

-> Choose Start (F5) from the Run menu in order to Run the altered version of the model.
After beginning the run, follow through the sequence you learned previously to obtain a Graph.
The generalized Population has become Bacteria. With computers it is trivial to change

deer into bacteria and visa versa with the mere wave of an insertion point.

3) To get a more realistic time span for bacterial growth, Change the X-axis label
(controlled by the Xlabel) from "Time (days)" to "Time (hours)" on your own and rerun to verify
that you have successfully made the change. You should now have Bacteria growing up on an
hourly basis. See, it's easy!

B) Changing the X and Y Scales - More practice editing

The lower and upper values for the graph X & Y axes are controlled by the values given
the variables xMin, xMax, yMin & yMax. These are assigned in the section right above the one
you have been working in. You will now double the value of yMax , squashing the resultant
displayed population size down to half the vertical height of the previous graph.

1) To find the words yMax and thereby locate the routine for editing:
-> Pick Find (CTRL-F) from the Edit menu. (look for the binoculars)
You get a Find dialog box.

->  Type yMax ( as the Find What text).
-> Click Find Next.

The List window now shows yMax selected (i.e.darkened). If this is not in the section
you wish (i.e. in the --Define Graph Maxima and Minima--- section) you can continue the 'Find'
Next as many times as you wish by either

- reclicking on Find Next or pulling down Find Next (F3) again from Edit menu.

-> Close the Find window (click upper right X close box).



2) To change yMax to double its current value.

-> Locate the line yMax = 50

-> Click between the = and the 5.

-> Still holding down the button, drag rightward across the 5 and the zero so that 50 is
completely selected (darkened). You have selected this entire block of text to operate on.

-> Select Cut (CTRL-X) from the Edit menu.

-> type in the new value, 100, for yMax.

Your line now reads:
yMax = 100 (if it doesn't, re-edit it until it does)

-> RUN the model to test your changes out.
(Notice that most frequently used commands, such as RUN, have shortcuts. Thus RUN can be activated by
holding down the Function key F5).

VIIl.  Editing the model itself

Thus far, you have practiced editing by changing the format of the output of the model (in
this case the output is a graph). The model itself (i.e. the straight-line linear relationship
between population and time) has been left untouched. We will now practice altering the
model itself by editing it.

A) Looking over the model List
-> Use the Find function to locate the words "Assign" in the section
'‘Assign Constants and Initial Conditions

-> Use scroll arrows to place this section that begins with :
'---Assign constants
at the top of your code window screen.

You should scan the following specific lines and study their function until you understand
how this section works.

'---assign constants and initial conditions--- 'supplies starting values to your model

K=1 'growth constant, e.g people/day
N=0 'start w/ no organisms for initial pop
T=0 'starts experiment at time = 0
dt=1 increment of time
Tkkkkkkkkkkkhkkhkkhkkkhkkhkkkkkkkhkkkhkkkhkkhkkkhkkkkhkkkkkkkkkkkhkkkkkkkk
'Call Procedure to set up Graph and axis 'sets up your graph
SetupGraphandAxis ‘according to xMax, etc.

LastX = 0: LastY =0

Vhkkkkhkkkkhkkkkhkhkkkkkkkkk R un M Od e |*************************

Do While T < 60 ‘executes until time exceeds 60 units
N=K*T
T=T+dt

X1 =T:Y1=N: StyleType = 0: PlotPoint ‘assigns time to x axis & pop. to y axis then plots graph

Loop 'go back until time exceeds 60
Thkkkkhkkkkhkkkkhkhkkkhkhkkkkhkhkhkhkhkkkkhkkhkhkhkkkkhkkkhkhkkkkkkkkhkkkkk

Vhkkkkhkkkkhkkkkhkhkkkkhkkkkhkkkkhkhkkkkhkkhkhkhkkkkhkkkhkhkkkkkkkkhkkkkk



B) Changing a constant
We all understand that in the model equation N = K * T, K controls the steepness (slope)

of the population growth. We will now change it.
In the 'Assign Constants and Initial Conditions section:
-> place the insertion point right after the 1 in K = 1.
-> <Backspace> over the number 1.
-> Type in 0.5. (half as steep a growth rate). [be sure to use zero, not the letter "0"1]
-> RUN (F5) the model.
Observe the results and then pick Exit to end the model.
-> Change the K back to 1.0.

C) Changing the model equation
This simplified model is not really a very realistic model of population growth. One

shortcoming is that the initial population is zero! Populations start to grow from some initial
(time=0) positive value (unless Lamark was correct about spontaneous generation!). We will
now alter the model to include such a term by letting NO (N at time zero) represent the initial
population. To implement this change requires several steps. (Note: be careful to not confuse zero
(0) and the letter "0" when typing models)

1) Change the model equation to include the new term NO.
Do this by editing the equation in the ('Do While' section of the) List. Your final equation
should read:
N=NO+K*T
That is, at T = 0 the curve will start at Y = NO and rise from there in a straight line with a slope
= K. Notice that in BASIC, the asterisk symbol (i.e. *) is used for multiplication. The remainder

of the common operators are more familiar ( + for addition, - for subtraction and / for division).
[ also take care to note the difference between UPPER & LOWER CASE as each letter is different. BASIC does not
recognize NO and n0 as being the same entity!]

2) Now that your model equation now has an initial population (NO) term in it, you must
assign it an initial value. To do so, change the 'Assign Constants and Initial Conditions section
as follows:

-> add a new line NO = 10 (this starts the population at 10).
You can obtain a new line to write on by placing the cursor at the end of the previous line and
pressing the <Return> key.

-> add your new line after the N = 0 line

-> now RUN (F5) your model again & observe the new curve.

X. Saving a new version of a model

You now have a new model that you might wish to save on disk, print the output
(graph) of or get a printed Listing of. Below you get practice in each of these forms of
documentation. These are the three of the four forms of documentation you need to hand in to
satisfy any course modeling assignment.

A) To Save a model
To save a model to disk, so that you can run it later or make further changes in it, use
Save Project As... to put the program on the disk. Once it's on the disk, you can load it, run it
or whatever you like (and you avoid accidentally overwriting your previous model).




-> choose the Save Project As... command from the File menu.
(Note well: Always use the PROJECT save option, not any other save option!)
This gives you a Save dialog box

Note that BASIC assumes you want to save the program under its current name MasterModel.
It is usually a good idea to type in a new name so as to not overwrite (i.e. permanently wipe
out!) the previous version. You may find that you will again need the old version at some future
time.

-> Edit the old File name (MasterModel) out (Cut or <Backspace>).

-> Type in LinearPopModel or whatever you wish for a usefully descriptive name.

-> Verify that the type is Project Files (*.vbp). (the only type we work with in Biomodeling)

-> If necessary navigate to your data disk and Save in the folder Weekl1/MasterModel/ (or
as appropriate)

In theory, you can Save to any available volume on the desktop. In practical terms, you
almost always want your new models stored on your data disk (which normally will be in the
drive slot). You certainly do NOT want to save to the hard drive or any file server because you
want to be able to walk out with the model in hand on your disk. After naming the model and
picking your data disk & appropriate folder as its’ destination,

-> Click the Save button (or press the <Return> key).

You now have both the original model and your newer one stored on your disk. It is a wise
policy to save very frequently since any kind of a power dip , machine crash or error in your
model while you are working (rare but catastrophic events) could cause all your work in
computer memory to vanish. If it is on disk, it is safe and you can always call it back after re-
powering up.

B) Printing a Model Listing
You will find it much easier to debug a model by looking at a printed paper copy
LISTing than at the screen text. In addition, you will want a LIST to hand in to me for each
working model. The steps below outline how to PRINT a LIST.
1) Select a truncated version for printing
You truncate by selecting out all of the material in the window only the section

Private Sub cmdRunModel_Click()

I***********************(3et\/ahJeS************************

'‘Define Graph Maxima and Minima

Loop

Vhkkkkhkkkkhkkkkhkhkkkhkhkkkkhkhkhkkhkhkkkhkhkkhkhkhkkkhkhkkkkhkhkkkkkkkkkhkkkk

Vhkkkkhkkkkhkkkkhkhkkkhkhkkkkhkkkkhkhkkkkhkkhkhkhkkkhkhkkkkhkhkkhkkkkkhkkkkk

This, of course, is the entire model without any of the rest of the course routines.



You now have just your model in BASIC selected, minus its graphing routines. To Print it,
simply select Print from the File menu and verify that you are printing only the selection. Click
on the OK button. Your output should appear in a Dana 181 printer or whatever printer you
have selected on the desktop under Start (lower left) -> Settings -> Printers.

Xl. Printing Graphic Output

Having now learned how to print the List (i.e. the math instructions) of a model, we turn to
how to make a hard copy of the output of a model (i.e. its behavior when it actually Runs,
usually a graph. less often a table, sometimes a statistical summary).

Actually you have already done this above. Recall that to Print a graph you simply Run
the model through having it Graph itself and then click on the Print command button.

After Printing, pick Exit to end the model run and return to the model code itself.

XIll. To exit Visual Basic
Select Quit from File. You return to the Windows 2000 desktop.

XI. To retrieve your disks & quit the machine.
-> Floppy’s are ejected by manually pushing the floppy drive eject butt.
-> Next select Shut Down from the desktop's Start menu.




